HTC сообщила об обнаружении уязвимости в некоторых своих смартфонах

Компания HTC сообщила об обнаружении серьезной уязвимости в некоторых своих смартфонах, работающих под управлением операционной системы Google Android. Данная уязвимость проявляется в том, что смартфон позволяет делать видимыми учетные данные настроек безопасности беспроводных сетей Wi-Fi, к которым осуществлено подключение.

Таким образом, злоумышленники могут получить доступ к беспроводным сетям и подключенным к таким сетям компьютерам и мобильным устройствам. Согласно озвученной информации, уязвимость обнаружена в следующих моделях смартфонов: Desire HD версий FRG83D, GRI40; Glacier версии FRG83; Droid Incredible версии FRF91; Thunderbolt 4G версии FRG83D; Sensation Z710e версии GRI40; Sensation 4G версии GRI40; Desire S версии GRI40; EVO 3D версии GRI40; EVO 4G версии GRI40. Исследователи Крис Хессинг (Chris Hessing) и Брет Джордан (Bret Jordan) выявили данную уязвимость еще 7 сентября 2011 года. С тех пор они работали совместно с компаниями HTC и Google для ее устранения.

При этом, компания HTC уведомила пользователей, что большинство смартфонов уже получили автоматически патч, исправляющий выявленную уязвимость, через сервис регулярных обновлений. Однако в некоторых случаях пользователям предстоит загрузить обновление и внести исправления самостоятельно. В связи с этим рекомендуется на следующей неделе проверить наличие дополнительной информации по решению данной проблемы, и, в случае необходимости, загрузить обновление вручную. Поэтому всем владельцам указанных аппаратов рекомендуется посетить сайт службы поддержки HTC.